CVE-2021-38299GHSA-6WHF-Q6P5-84WG
Webauthn Framework 3.3.x before 3.3.4 has Incorrect Access Control.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.3.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Webauthn Framework 3.3.x before 3.3.4 has Incorrect Access Control. An attacker that controls a user's system is able to login to a vulnerable service using an attached FIDO2 authenticator without passing a check of the user presence.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- web-auth/webauthn-frameworkPackagist
From 3.3.0 · fixed in 3.3.4