CVE-2021-37941GHSA-R562-M862-63W3PYSEC-2026-634
A local privilege escalation issue was found with the APM Java agent, where a user on the system could attach a malicious file to an applica
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.27.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A local privilege escalation issue was found with the APM Java agent, where a user on the system could attach a malicious file to an application running with the APM Java agent. Using this vector, a malicious or compromised user account could use the agent to run commands at a higher level of permissions than they possess. This vulnerability affects users that have set up the agent via the attacher cli 3, the attach API 2, as well as users that have enabled the profiling_inferred_spans_enabled option
Timeline
- CVE published
- Record last updated
Affected versions
- Elastic APM Java Agent
1.10.0 through 1.26.0
- elastic-apmPyPI
From 1.10.0 · fixed in 1.27.0