CVE-2021-37404GHSA-RMPJ-7C96-MRG8
Heap buffer overflow in libhdfs native library
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.3.2, 3.2.3, 2.10.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Hadoop
2.9.0 to 2.10.1, 3.0.0 to 3.1.4, 3.2.0 to 3.2.2, 3.3.0 to 3.3.1
- org.apache.hadoop:hadoop-commonMaven
From 3.3.0 · fixed in 3.3.2
- org.apache.hadoop:hadoop-commonMaven
From 3.0.0 · fixed in 3.2.3
- org.apache.hadoop:hadoop-commonMaven
fixed in 2.10.2