CVE-2021-36783GHSA-8W87-58W6-HFV8
Rancher: Failure to properly sanitize credentials in cluster template answers
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.6.4, 2.5.13
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A Insufficiently Protected Credentials vulnerability in SUSE Rancher allows authenticated Cluster Owners, Cluster Members, Project Owners and Project Members to read credentials, passwords and API tokens that have been stored in cleartext and exposed via API endpoints. This issue affects: SUSE Rancher Rancher versions prior to 2.6.4; Rancher versions prior to 2.5.13.
Timeline
- CVE published
- Record last updated
Affected versions
- SUSE Rancher
From Rancher · fixed in 2.6.4
- SUSE Rancher
From Rancher · fixed in 2.5.13
- github.com/rancher/rancherGo
From 2.5.0 · fixed in 2.5.13
- github.com/rancher/rancherGo
From 2.6.0 · fixed in 2.6.4