CVE-2021-36778GHSA-4FC7-HC63-7FJG
Exposure of repository credentials to external third-party sources
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.5.12, 2.6.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A Incorrect Authorization vulnerability in SUSE Rancher allows administrators of third-party repositories to gather credentials that are sent to their servers. This issue affects: SUSE Rancher Rancher versions prior to 2.5.12; Rancher versions prior to 2.6.3.
Timeline
- CVE published
- Record last updated
Affected versions
- SUSE Rancher
From Rancher · fixed in 2.5.12
- SUSE Rancher
From Rancher · fixed in 2.6.3
- github.com/rancher/rancherGo
From 2.6.0 · fixed in 2.6.3
- github.com/rancher/rancherGo
From 2.5.0 · fixed in 2.5.12