Skip to main content
← All vulnerabilities
CVE-2021-36374GHSA-5V34-G2PX-J4FW

Apache Ant ZIP, and ZIP based, archive denial of service vulerability

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.9.16, 1.10.11
None on Exploit-DB, Metasploit or GitHub

Summary

When reading a specially crafted ZIP archive, or a derived formats, an Apache Ant build can be made to allocate large amounts of memory that leads to an out of memory error, even for small inputs. This can be used to disrupt builds using Apache Ant. Commonly used derived formats from ZIP archives are for instance JAR files and many office files. Apache Ant prior to 1.9.16 and 1.10.11 were affected.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache Ant

    From 1.4; From Apache Ant 1.9.x · through 1.9.15; From Apache Ant 1.10.x · through 1.10.10

  • org.apache.ant:antMaven

    From 1.9.0 · fixed in 1.9.16

  • org.apache.ant:antMaven

    From 1.10.0 · fixed in 1.10.11

References 11

ant.apache.org

lists.apache.org

oracle.com

security.netapp.com