Skip to main content
← All vulnerabilities
CVE-2021-36373GHSA-Q5R4-CFPX-H6FH

Apache Ant TAR archive denial of service vulnerability

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.9.16, 1.10.11
None on Exploit-DB, Metasploit or GitHub

Summary

When reading a specially crafted TAR archive an Apache Ant build can be made to allocate large amounts of memory that finally leads to an out of memory error, even for small inputs. This can be used to disrupt builds using Apache Ant. Apache Ant prior to 1.9.16 and 1.10.11 were affected.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache Ant

    From Apache Ant 1.9.x · through 1.9.15; From Apache Ant 1.10.x · through 1.10.10

  • org.apache.ant:antMaven

    fixed in 1.9.16

  • org.apache.ant:antMaven

    From 1.10.0 · fixed in 1.10.11

References 11

ant.apache.org

lists.apache.org

oracle.com

security.netapp.com