Skip to main content
← All vulnerabilities
CVE-2021-36090GHSA-MC84-PJ99-Q6HH

Apache Commons Compress 1.0 to 1.20 denial of service vulnerability

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.21
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

When reading a specially crafted ZIP archive, Compress can be made to allocate large amounts of memory that finally leads to an out of memory error even for very small inputs. This could be used to mount a denial of service attack against services that use Compress' zip package.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Apache Software Foundation Apache Commons Compress

    From Apache Commons Compress · through 1.20

  • org.apache.commons:commons-compressMaven

    fixed in 1.21

References 25

commons.apache.org

lists.apache.org

openwall.com