Skip to main content
← All vulnerabilities
CVE-2021-36043GHSA-36XQ-7W8W-XP68

Magento Commerce Authenticated Blind SSRF Could Lead To Remote Code Execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.7-p1, 2.4.2-p2
None on Exploit-DB, Metasploit or GitHub

Summary

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by a blind SSRF vulnerability in the bundled dotmailer extension. An attacker with admin privileges could abuse this to achieve remote code execution should Redis be enabled.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.2; through 2.4.2-p1; through 2.3.7

  • magento/project-community-editionPackagist

    through 2.0.2

  • magento/community-editionPackagist

    fixed in 2.3.7-p1

  • magento/community-editionPackagist

    2.3.7

  • magento/community-editionPackagist

    From 2.4.2-p1 · fixed in 2.4.2-p2

  • magento/community-editionPackagist

    2.4.2

References 1

helpx.adobe.com