CVE-2021-36039GHSA-3G7M-G8QM-X6J5
Magento Commerce `quoteId` parameter Incorrect Authorization Vulnerability Could Lead To Information Disclosure
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.7-p1, 2.4.2-p2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability via the `quoteId` parameter. An attacker can abuse this vulnerability to disclose sensitive information.
Timeline
- CVE published
- Record last updated
Affected versions
- Adobe Magento Commerce
through 2.4.2; through 2.4.2-p1; through 2.3.7
- magento/project-community-editionPackagist
through 2.0.2
- magento/community-editionPackagist
fixed in 2.3.7-p1
- magento/community-editionPackagist
2.3.7
- magento/community-editionPackagist
From 2.4.2-p1 · fixed in 2.4.2-p2
- magento/community-editionPackagist
2.4.2