CVE-2021-36023GHSA-8CJG-F53M-8M9QBIT-MAGENTO-2021-36023
Magento Commerce Widgets Update Layout XML Injection Vulnerability Could Lead To Remote Code Execution
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.7-p1, 2.4.2-p2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection vulnerability in the Widgets Update Layout. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Adobe Adobe Commerce
through 2.3.7
- magento/project-community-editionPackagist
through 2.0.2
- magento/community-editionPackagist
fixed in 2.3.7-p1
- magento/community-editionPackagist
2.3.7
- magento/community-editionPackagist
From 2.4.2-p1 · fixed in 2.4.2-p2
- magento/community-editionPackagist
2.4.2