CVE-2021-33829GHSA-RGX6-RJJ4-C388BIT-DRUPAL-2021-33829DRUPAL-CORE-2021-003
A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attack
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.16.1, 7.80, 8.9.16, 9.0.14, 9.1.9
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 Nuclei template
Summary
A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- ckeditor4npm
From 4.14.0 · fixed in 4.16.1
- drupal/corePackagist
From 7.0.0 · fixed in 7.80
- drupal/corePackagist
From 8.0.0 · fixed in 8.9.16
- drupal/corePackagist
From 9.0.0 · fixed in 9.0.14
- drupal/corePackagist
From 9.1.0 · fixed in 9.1.9
- drupal/drupalPackagist
From 7.0.0 · fixed in 7.80
- drupal/drupalPackagist
From 8.0.0 · fixed in 8.9.16
- drupal/drupalPackagist
From 9.0.0 · fixed in 9.0.14
- drupal/drupalPackagist
From 9.1.0 · fixed in 9.1.9
- drupal/corePackagist
From 8.0.0 · fixed in 8.9.16; From 9.0.0 · fixed in 9.0.14; From 9.1.0 · fixed in 9.1.9