CVE-2021-33036GHSA-58JX-F5RF-QGQF
Apache Hadoop Privilege escalation vulnerability
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.10.2, 3.2.3, 3.3.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Hadoop
Version range not reported
- org.apache.hadoop:hadoop-yarn-server-commonMaven
From 2.2.0 · fixed in 2.10.2
- org.apache.hadoop:hadoop-yarn-server-commonMaven
From 3.0.0 · fixed in 3.2.3
- org.apache.hadoop:hadoop-yarn-server-commonMaven
From 3.3.0 · fixed in 3.3.2