CVE-2021-32862PYSEC-2022-249GHSA-9JMQ-RX5F-8JWQGHSA-H274-FCVJ-H2WM
nbconvert vulnerable to cross-site scripting (XSS) via multiple exploit paths
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 6.3.0a0, 6.5.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The GitHub Security Lab discovered sixteen ways to exploit a cross-site scripting vulnerability in nbconvert. When using nbconvert to generate an HTML version of a user-controllable notebook, it is possible to inject arbitrary HTML which may lead to cross-site scripting (XSS) vulnerabilities if these HTML notebooks are served by a web server (eg: nbviewer).
Timeline
- CVE published
- Record last updated
Affected versions
- jupyter nbconvert
through 6.2
- nbconvertPyPI
fixed in 6.3.0a0
- nbconvertPyPI
fixed in 6.5.1