Skip to main content
← All vulnerabilities
CVE-2021-32811GHSA-G4GQ-J4P2-J8FRPYSEC-2021-368PYSEC-2021-370

Remote Code Execution via Script (Python) objects under Python 3

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.6.3, 5.3, 4.3, 5.2
None on Exploit-DB, Metasploit or GitHub

Summary

Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • zopefoundation Zope

    From 4.0 · fixed in 4.6.3; From 5.0 · fixed in 5.3

  • zopePyPI

    From 4.0 · fixed in 4.6.3

  • zopePyPI

    From 5.0 · fixed in 5.3

  • accesscontrolPyPI

    From 4.0 · fixed in 4.3; From 5.0 · fixed in 5.2

  • zopePyPI

    From 4.0 · fixed in 4.6.3; From 5.0 · fixed in 5.3

References 3

GitHub · zopefoundation/Zope

GitHub · zopefoundation/AccessControl