Skip to main content
← All vulnerabilities
CVE-2021-32770GHSA-RQJW-P5VR-C695

Basic-auth app bundle credential exposure in gatsby-source-wordpress

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.8, 5.9.2
None on Exploit-DB, Metasploit or GitHub

Summary

Gatsby is a framework for building websites. The gatsby-source-wordpress plugin prior to versions 4.0.8 and 5.9.2 leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected. A patch has been introduced in gatsby-source-wordpress@4.0.8 and gatsby-source-wordpress@5.9.2 which mitigates the issue by filtering all variables specified in the `auth: { }` section. Users that depend on this functionality are advised to upgrade to the latest release of gatsby-source-wordpress, run `gatsby clean` followed by a `gatsby build`. One may manually edit the app.js file post-build as a workaround.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • gatsbyjs gatsby

    fixed in 4.0.8; From 5.0.0 · fixed in 5.9.2

  • gatsby-source-wordpressnpm

    fixed in 4.0.8

  • gatsby-source-wordpressnpm

    From 5.0.0 · fixed in 5.9.2

References 1

GitHub · gatsbyjs/gatsby