Skip to main content
← All vulnerabilities
CVE-2021-32668GHSA-6MH3-J5R5-2379BIT-TYPO3-2021-32668

Cross-Site Scripting in Query Generator & Query View

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.5.29, 10.4.18, 11.3.1, 8.7.41, 9.5.28
None on Exploit-DB, Metasploit or GitHub

Summary

TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When error messages are not properly encoded, the components QueryGenerator and QueryView are vulnerable to both reflected and persistent cross-site scripting. A valid backend user account having administrator privileges is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this issue.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • TYPO3 TYPO3.CMS

    From 9.0.0 · fixed in 9.5.29; From 10.0.0 · fixed in 10.4.18; From 11.0.0 · fixed in 11.3.1

  • typo3/cms-corePackagist

    From 8.0.0 · fixed in 8.7.41

  • typo3/cms-corePackagist

    From 9.0.0 · fixed in 9.5.28

  • typo3/cms-corePackagist

    From 10.0.0 · fixed in 10.4.18

  • typo3/cms-corePackagist

    From 11.0.0 · fixed in 11.3.1

  • typo3/cmsPackagist

    From 10.0.0 · fixed in 10.4.18

  • typo3/cmsPackagist

    From 11.0.0 · fixed in 11.3.1

  • typo3/cmsPackagist

    From 9.0.0 · fixed in 9.5.28

References 2

GitHub · TYPO3/TYPO3.CMS

typo3.org