CVE-2021-32667GHSA-8MQ9-FQV8-59WFBIT-TYPO3-2021-32667
Cross-Site Scripting in Page Preview
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 9.5.29, 10.4.18, 11.3.1, 9.5.28
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When Page TSconfig settings are not properly encoded, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this issue.
Timeline
- CVE published
- Record last updated
Affected versions
- TYPO3 TYPO3.CMS
From 9.0.0 · fixed in 9.5.29; From 10.0.0 · fixed in 10.4.18; From 11.0.0 · fixed in 11.3.1
- typo3/cms-corePackagist
From 9.0.0 · fixed in 9.5.28
- typo3/cms-corePackagist
From 10.0.0 · fixed in 10.4.18
- typo3/cms-corePackagist
From 11.0.0 · fixed in 11.3.1
- typo3/cmsPackagist
From 10.0.0 · fixed in 10.4.18
- typo3/cmsPackagist
From 11.0.0 · fixed in 11.3.1
- typo3/cmsPackagist
From 9.0.0 · fixed in 9.5.28