Skip to main content
← All vulnerabilities
CVE-2021-32476GHSA-4QXC-QXRP-33CWBIT-MOODLE-2021-32476

A denial-of-service risk was identified in the draft files area, due to it not respecting user file upload limits.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.10.4, 3.9.7, 3.8.9, 3.5.18
None on Exploit-DB, Metasploit or GitHub

Summary

A denial-of-service risk was identified in the draft files area, due to it not respecting user file upload limits. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a moodle

    Version range not reported

  • moodle/moodlePackagist

    From 3.10 · fixed in 3.10.4

  • moodle/moodlePackagist

    From 3.9 · fixed in 3.9.7

  • moodle/moodlePackagist

    From 3.8 · fixed in 3.8.9

  • moodle/moodlePackagist

    From 3.5.17 · fixed in 3.5.18

References 1

moodle.org