Skip to main content
← All vulnerabilities
CVE-2021-32475GHSA-5WJH-V7C8-WRHXBIT-MOODLE-2021-32475

ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.5.18, 3.8.9, 3.9.7, 3.10.4
None on Exploit-DB, Metasploit or GitHub

Summary

ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a moodle

    Version range not reported

  • moodle/moodlePackagist

    From 3.5 · fixed in 3.5.18

  • moodle/moodlePackagist

    From 3.8 · fixed in 3.8.9

  • moodle/moodlePackagist

    From 3.9 · fixed in 3.9.7

  • moodle/moodlePackagist

    From 3.10 · fixed in 3.10.4

References 1

moodle.org